free hit
counters
Tach shows 300-1000 rpm's only - Engine/Ancilliaries - The Lotus Forums #ForTheOwners Jump to content


Tach shows 300-1000 rpm's only


Recommended Posts

Upon start up my tach reads 300 rpm's. At what should read 5k+ rpm's it only shows 1k at most. By which I mean it is getting some sort of a reading and always moves if the engine is running.... but never goes over 1k rpm's. My motor is definitely running over 1k rpm's. Also, my temp gauge recently stopped reading anything. Unsure if this is related.

Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.
  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

I would first double check your earths for these kind of instrument problems.

If the engine is running smoothly then I doubt that it is ECU related.

Mike S

1996 Esprit V8, 1998 Esprit V8 GT, 1999 Esprit S350 #002 (Esprit GT1 replica project), 1996 Esprit V8 GT1 (chassis 114-001), 1992 Lotus Omega (927E), 1999 Esprit V8SE, 1999 Esprit S350 #032, 1995 Esprit S4s, 1999 Esprit V8 GT (ex-5th Gear project), 1999 Esprit V8SE ('02 rear)

1999 S350 #002 Esprit GT1 replica

Link to post
Share on other sites

You could also check the OBD II readout of engine RPM to confirm the ECU output is good.

Edited by 73JPS

"At home, I have a King Sized bed. Now, I don't know any Kings, but I would imagine if one were to come over, he would be comfortable." -Mitch Hedberg

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



Upgrade today to remove Google ads and support TLF.


×
×
  • Create New...