free hit
counters
thermostat broke? - Engine/Ancilliaries - The Lotus Forums Jump to content


thermostat broke?


Recommended Posts

ok, i know im asking alot of questions, so sorry lol, but,

ive read a few posts about temeratures and things, my temp guage when im driving normally will stay around 60 degress, if i dirve harder it will go up towards 80, not often above it though, and if i idle in traffic for quite a while, it will also start to creep up towrads 80, never really been above it, i know guages are just for rough values, but i dont have freescan to test it via the ECU

do you think the thermostat is the problem?

or are these normaly temperatures?

what should the guage roughly read most of the time?

is there anyone around the bristol area that could run freescan on my car for me?

car is a 89 SE turbo, thanks :D

cheers, shaun

Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.
  • Replies 6
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Shaun,my car is not an SE but normally runs at about 80-85 degrees on the move depending on the ambient temperature.

Maybe check what spec thermostat your car is fitted with? Is one fitted?

See the forum shop for freescan cables. smile.gif

Link to post
Share on other sites

i was thinking about buying one, where does it actually plug into? the ecu itself? , cheers, shaun

was just wondering if there was anyone on here with one, i could drive over to them (when i get the idle problem sorted >.<) just have them check the values quickly for me :D save waiting for it in post etc, also if mine is running that cool, then apparently im loosing boost? due to the ecu not letting you have so much? i want that extra boost! lol

Link to post
Share on other sites
  • 2 weeks later...

I would change the thermostat very low cost item and easy to do. Car will not run correctly until temp has reached 82. yes there are two plugs for free scan one under the dash right side and other in rear in the relay /fuse box. jp

Link to post
Share on other sites

My 88 carb turbo has been running at a low temperature since I got the car 6 months ago although in heavy traffic it does start to heat up and the fans switch on. Took the cover off today and see the thermostat is not closing properly. It seems to be sticking partially open so problem solved and only for a few quid. Its vitally important to get an 82 degree thermostat.

Looking forward to an improved drive as I understand the turbo does not function correctly if car is running cold.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...