free hit
counters
Performance issue - Engine & Ancillaries/Gearbox - The Lotus Forums #ForTheOwners Jump to content


Recommended Posts

Used the Elise for the first time in a week. Started fine on the button and was driving with no issues for around 5 minutes.

Then under constant throtlle. the power drops off very slowly and continues as if it will stall if it were to carry on, then it returns with a jump and normal service is resumed for a few seconds or more before it goes on to repeat itself over and over again.

BUT only on constant throttle.

You can accelerate out of it, but then it returns under constant throttle again?

There are no fault codes registered.

No misfire.

Fine under progressive or hard acceleration.

The jump is not really violent, but is similar to a misfire for a brief moment although it is not!

Any thoughts?

Caught between a rock and a hard place in a catch 22 situation, So its 6 of one and half a dozen of the other. Your damned if you do, but your damned if you don't so shut your cock!!!!!!!!!!!

Lotus Espirt Turbo S3    

Lotus Esprit S4 

Lotus Elise S2 Sport 130

pig_zps6d7342f1.jpg

Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.
  • Replies 5
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Lotus Elise S2 135 Sport 02

88 Esprit NA, 89 Esprit Turbo SE, Evora, Evora S, Evora IPS, Evora S IPS, Evora S IPS SR, Evora 400, Elise S1, Elise S1 111s, Evora GT410 Sport

Evora NA

For forum issues, please contact the Moderators. I will aim to respond to emails/PM's Mon-Fri 9-6 GMT. 

Link to post
Share on other sites

Ok - rover K engine with cable throttle.

My bet would be it's a sensor... posisbly the thorttle position sensor.

They do wear out at an alarming rate and essentially just a pentiometer (think scalectrix controller) and if it wears out in one spot it can cause some unreliable issues.

You can pick them up on ebay for about 10 quid - any rover MGF Throttle sensor should do it.

http://cgi.ebay.co.uk/Rover-K-%2f-T-series-Throttle-position-Sensor.-late-type_W0QQitemZ140367108476QQcmdZViewItem?rvr_id=&rvr_id=&cguid=584283331230a0aad382f5d2ff86f911

I might have a couple knocking about.

Link to post
Share on other sites

Thanks Ads. I was thinking along thise lines. I will give it a go. Thankyou for the response and the link :lol: Thanks to Bibsy too for the car ID. Happy new year peeps.

Caught between a rock and a hard place in a catch 22 situation, So its 6 of one and half a dozen of the other. Your damned if you do, but your damned if you don't so shut your cock!!!!!!!!!!!

Lotus Espirt Turbo S3    

Lotus Esprit S4 

Lotus Elise S2 Sport 130

pig_zps6d7342f1.jpg

Link to post
Share on other sites

If the car has seen wet weather [heavy rain] you might want to pull the coil packs out and check for moisture. Any traped moisture in the spark plug tubes will boil after a few miniutes will cause arcing misfires and a loss of power under heavy load and return to normal at cruise..... This will need to happen a number of times before it throws a code....

I think it's fast enough…maybe

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...