free hit
counters
HELP engine probs - Engine/Ancilliaries - The Lotus Forums Jump to content
Sign in to follow this  
robdaniel

HELP engine probs

Recommended Posts

need help please, cant get my se to run right.runs fine on tickover but when i get to 3000 rpm it misses/backfires. have checked and rechecked connectors/pipes etc but cant seem to find anything. anyone got any ideas or in the north east area who might be able to help. i have freescan but dont realy know what to look for. starting to get me down. thanks rob

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

Capture a logfile, post it on here and I'm sure someone would take a look for you.

Don't let it get you down dudes, the answer is in here somewhere :thumbsup:

Share this post


Link to post
Share on other sites

Is your O2 sensor working correctly? Could be a fuel issue with supply at higher RPM, is the fuel pump working correctly? HT leads ok?

As Simon said, a log file paints a nice picture, please upload it here.

Share this post


Link to post
Share on other sites

it was a new o2 sensor last year wont have done 1500 miles since fitment so doubt it that. starting to think its a fueling problem, should you get fuel from the shrader valve with ign on or should it only let fuel out of valve when engine running. dont know if its me but the pump sounds more noisey tha normal. have attatched a couple of freescan logs if anybody knows what their looking for

fridays log.csv

lotus diagnostics.csv

Share this post


Link to post
Share on other sites

Just bumping this, can anyone take a look for Robin? Lets try and get him a fix.

Neither have, or ever used freescan so can't really help myself.

Share this post


Link to post
Share on other sites

Your O2 sensor is showing that the engine is running lean as the engine speed is increasing, I'm guessing that your fuel pump is struggling either due to a fault, blocked filter or similar.

Share this post


Link to post
Share on other sites

thanks bibs for taking the time to look at my freescan logs.. noticed reading a old post that mr.oogieboogie(peter philips) had a good used fuel pump. after contacting him he said i could have it FOC and he posted it as well. top bloke thanks. fit the new pump and hey presto its fixed. hope i can be of help and return the favor some day. big thank you Rob

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


×