free hit
counters
Lotus Elite Temp! - Engine & Ancilliaries/Gearbox - The Lotus Forums Jump to content
Sign in to follow this  
tonytransam

Lotus Elite Temp!

Recommended Posts

I have an elite 2.2 with a strange temperature problem. If i leave heater off the temp stays normal, if i switch the blower on it reads hotter. Any help would be appreciated, i have changed thermostat, otter switch new water pump etc etc. doesn't lose water or boil up.

Thanks in advance.

Edited by Roger Moore

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

Hi, as a long shot, the temperature gauge is electric, when you switch on the fans it could be affecting the voltage supply to the sender causing the resistance in the sender to change thus causing the gauge to read high. From memory the sender v+ supply goes from a voltage stabilizer at the back of the gauges through the temp gauge to the sender on the thermostat housing and then to earth. Has this supply been connected to a non stabalised supply?

Regards Dan

Share this post


Link to post
Share on other sites

I'd go with what Dan posted, or similarly the fan may be altering the supply of 10v (think it's 10V) or earth to the dial.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


×