free hit
counters
Cannot establish connection - ECU/Freescan/Espritmon - The Lotus Forums Jump to content
Sign in to follow this  
mrbeanieca

Cannot establish connection

Recommended Posts

Hi just need some ideas on getting connection though the ALDL cable.

I tried different laptops (with RS232 and USB) and different programs (Freescan and Espritmon) but still couldn't establish connection to get data from the car (94 Esprit S4). Could the cable itself be defective?

Is there any one in the GTA (Toronto) who has a working cable and freescan that I can come by and read my codes?

Thanks in advance

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

Thanks Guys.....it's a RS232 cable and I'm using a USB to RS232 converter on my laptop. I will try installing the drivers suggested by Bibs and report back...

Share this post


Link to post
Share on other sites

I'm fairly certain that it won't work, our USB cables have a chip which sorts out the baud rate to work correctly and just a converter doesn't cut the mustard.

Share this post


Link to post
Share on other sites

Hi, as far as I know, USB to serial cables that use the FTDI chipset have no problem with the 8192 baud rate.

For those cables that use a prolific chipset, there is a simple hack by adding a setting to the registry to talk at 8192 baud.

I haven't encountered a USB 2 serial cable yet that could not be taught to talk at 8192 baud.

Do you know what chipset is in your converter? In most cases you can deduce it from the name of the drivers or dll that is used.

Erik

Share this post


Link to post
Share on other sites

The bloke who makes them is a member on here, I'm sure he'll let us know.

Share this post


Link to post
Share on other sites

Hi Erik, the chipset is Profilic. I did add the registry key to set baud rate at 8192 as per instructions from your site, but still no luck. Perhaps I didn't add the key properly...

Erik

Share this post


Link to post
Share on other sites

Are you sure you are connecting to the right ALDL connector? Which one are you connecting to?

Share this post


Link to post
Share on other sites

Hi Erik,

You mention 8192 baud and that is correct, but the (integer) divider constant that is used to obtain this baudrate can only yield an approximation, in this case 8200. Did you use 8200 both in the lotus.cfg file and the registry entry, e.g. as follows:

[HKEY_LOCAL_MACHINE \ SYSTEM \ CurrentControlSet \ Services \ Ser2pl]

"ExtBaudrate"="8200,2147485879"

and in lotus.cfg

mode=0

com=4

baudrate=8200

gpscom=0

gpsbaudrate=115200

!! The number of the comport may be different for your USB2Serial adapter.

Applications that try to open the port at 8192 will not get the 8200 and typically windows will still set 9600 baud. Hence Freescan may require either a cable with the FTDI chipset or you need to recompile it to change the 8192 into 8200.

That is done by modifying the following code (line 68 in the file serialinterface.h)

BOOL InitPort(CWnd* pPortOwner, UINT portnr = 1, UINT baud = 8192, char parity = 'N',

Good luck,

Erik

Share this post


Link to post
Share on other sites

As asked above, are you trying to connect to the ALDL connector behind the glove box or in the boot? I have found my connector behind the dashboard to only work intermittently (loose wire probably). Also, there is another ALDL connector for the alarm system there too so make sure you are not plugged into that.

Edited by sailorbob

Share this post


Link to post
Share on other sites

Thanks again guys....here is the latest...

I found a docking station for my laptop so I now have a proper serial port. Tried that and still no luck. I tried both ALDL ports under the dash (one is connected, and the other is terminated with a cap).

My question is, what baud rate do I need to set COM1 to for the serial port? It's set at 9600 Baud and I can't seem to change it so 8192 as it's not one of the available choices in the drop down list.

Thanks for all your help again...

Erik

Share this post


Link to post
Share on other sites

I use COM1 on my laptop, set at 9600 bps, 8 bit, no parity, stop bits 1, no flow control and this works OK with Freescan.

Share this post


Link to post
Share on other sites

Both Freescan and Espritmon initialize the comport at the required baud rate, so the windows settings are overwritten anyway. I guess that whatever you select in windows does not matter to either Freescan or Espritmon. From all the attempts that failed I would slowly start to suspect the cable.

Do you have access to an oscilloscope to test it?

Erik

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


×