free hit
counters
Battery Disconnect / Intermittent problem - Engine & Ancillaries/Gearbox - The Lotus Forums Jump to content
Sign in to follow this  
cphbc

Battery Disconnect / Intermittent problem

Recommended Posts

Just wondering if anyone has had a problem with their Battery Disconnect / Kill switch [ located behind passenger seat]

I had a problem on the track the other day , car just stopped after a medium G corner, then promptly started going again .

Carried on back into the pits , checked everything , but could not locate a problem.

Carried on for the rest of the day , no issues .

Only when I got home and went to Turn the Battery disconnect on, did I notice that it did not activate the ignition , gave it a bit of a wiggle and it worked .

Have checked the terminals and all tight and appear ok .

Next step is complete disassembly , but thought someone may have prior knowledge of the problem.

Cheers

Barry

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

Do you keep the dust cap on when not in use, just wondering if some gunk has got in the top fouling the disconnect.

If you had to wiggle the battery key to get it to workbthen that's where my money would be. The switch is fairly well mounted so any movement if the key shouldn't affect the conections.

Ads

Share this post


Link to post
Share on other sites

The cap is always on , but purchased 2nd hand so may not have been the case previously .

Will clean it out and see if it fixes the problem .

Thanks

Share this post


Link to post
Share on other sites

All sorted , a good clean out and some WD40 and its all ok .

Thanks for the helpful info .

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


×