free hit
counters
Barometric & Map Sensor Volts - Engine/Ancilliaries - The Lotus Forums Jump to content
Sign in to follow this  
Chris89turbo

Barometric & Map Sensor Volts

Recommended Posts

We found something interesting the other night, and I am hoping I can get some feedback. I am wondering if I may have uncovered the possbile mystery of my running problem.

The voltage on the Map Sensor with the key on & the engine off is suppsed to be 2.45 volts at sea level. We hooked a DVOM Multi Meter to the actual wires at the Map Sensor, and we are reading 2.21 volts (but Freescan gives us a 0.8 volt reading)... The Barometer is giving us a 4.4 volt reading at the wire next to the sensor when using the Multi Meter, but Freescan is giving us a 0.7 volt reading... Wondering if maybe the ECM is giving false reasing & that is what is causing my car to run rich, and stumble & missfire...

Any feedback?

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

You can read voltage commonly 1 of 3 ways.

Voltage with respect to the load.

Voltage drop across a load.

Voltage with respect to earth.

Which one are you measuring ? :cheers:

Catch my drift ?

You want to probe the wires at the ECU with respect to earth or -ve, appologies if you're already doing that.

Also be careful of using battery voltage, I've seen people probe away on battery circuits thinking they have 12 or what ever volts only to find out they dont have that at all, make sure the refrences are as you expect first.

Share this post


Link to post
Share on other sites

On both sensors, reference voltage was tested to chassis ground. The harness ground was verified by ohms, then signal voltage was measured between it and harness ground with harness plugged into sensor.

Share this post


Link to post
Share on other sites

Yeah you need to probe to the ECU in all honesty.

Ensure the netural is on the battery -ve terminal for the best results, it's common to have ~1ohm to neutral from a chassis point which really affect the reading - it's also worth grabbing the manual becuase that'll tell you what the ECU reads from each sensor and how they sense what they are sensing !

The ECU will either measure the volt drop across the sensor, or with respect to earth.

Share this post


Link to post
Share on other sites

That is the plan tonight (to check the wires at the ECU).... If we get the same readings at the ECU that we get at the sensors, then I was looking for some additional feedback on what the thoughts were that it would be the ECU.

The readings from Freescan are different than the Multi Meter when tested in the same manor... That throws a big red flag up for me..

thoughts?

Share this post


Link to post
Share on other sites

Yeah it's possible - ask Johny Welch if he has an ECU tester, just un-plug it and get it tested.

I know of 2-3 that have gone south but it should be last resort, what are your values in a freescan log ?

This is not to be confused with voltage as readings for freescan are often just a vlue (unless stated a voltage)

Baro should be close to 0.85 at sea level, MAP should be 0.5ish at idle, increase to about 1.0 with revs and then drop to 0.0 (or even negatives) when you lift off the throttle.

If I get time I might have a look at the car and see what measurements I read from it for ref (the GT2 is an SE same as yours).

Keep an open mind as they say.

Share this post


Link to post
Share on other sites

Very interesting... That makes sense. We were WAY off... We got the following readings (but we need to get more. We had 5 minutes to look tonight):

Ignition On (not running) - Meter readings taken at the sensors

Map Sensor

Freescan - 0.840 reading

Meter - 2.24 volts

Barometer

Freescan - 0.790 reading

Meter - 4.4 volts

Ignition on (car running at idle)

Map Sensor

Freescan - 0.57 - 0.60 reading

Meter - 1.67 - 1.69 volts

Barometer

Same readings as above (with engine NOT running, and ignition on)

What do you mean "what are my values in Freescan log"?

We will get the idle readings & rev reading next time we hook up... hopefully tomorrow night.

Share this post


Link to post
Share on other sites

When you log freescan's results into a CSV file you get the values, off the top of my head...are these from the blue screen in Freescan ?

If so they are correct, many people do get misled believing they are voltages when they are actually just values.

If you log the freescan results into a csv you will notice in the results there are specific columns in the file with voltages on (coolant has one, so does the MAT, and TPS) O2 sensor is about the only one there actally expressed as a voltage which doesn't have a V next to it's header iirc.

When you look your freescan readings they are exactly what I predicted.

When off the MAP sensor reads the same as the BARO, when switched on it falls to about 0.5 otherwise there would be no flow of air from the outside world into the engine.

Share this post


Link to post
Share on other sites

If anyone ever wants to play around with 3 bar sensors, I still have 3 pieces left over...

One needs to hard wire the ecu or change the chip programming. later seems to be close to unreachable....

cheers

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


×