free hit
counters
LED rear lights flashing too fast. - Interior/Exterior/Lights/Glass/Alarms/ICE/HVAC - The Lotus Forums Jump to content
Sign in to follow this  
ttv8

LED rear lights flashing too fast.

Recommended Posts

My 2004 Esprit has LED rear lights that were installed at the dealer but the fast blinking problem has never been corrected. They have changed the flasher but it continues to flash fast. This last time they claim it is a problem with the voltage regulator but it is not worth changing the alternator. I started to take manners into my own hands and install a resistor but came across a ballast module (25W) which i have no idea what this part does, so i wanted to know if anyone has come across this part and if a resistor could be installed to correct the fast flash on the output wires of this ballast module.

Thanks

Ruben

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

Rubin, I installed a load resister to slow sown the blinking on mine when I switched to LED rear lights... That slowed them down to normal for me...

http://www.superbrightleds.com/cgi-bin/store/index.cgi?action=DispPage&Page2Disp=%2Ftail-brake-turn.html

Cheers

Felix

Share this post


Link to post
Share on other sites

Hi , and thanks for the response. Are your lights the OEM lights with all the parts requested for the installation or aftermarket?

Share this post


Link to post
Share on other sites

Rear lights are OEM leds, the front bulbs have been replaced with suitable leds.

Share this post


Link to post
Share on other sites

I will try using the flasher you have and see if this works for me. I will keep you posted.

Thanks

Ruben

Share this post


Link to post
Share on other sites

I understand that if LED lights are used in place of standard incandecent bulbs, the relay for turn signals also needs to be replaced with a solid state module. The problem is that LED lights don't draw enough current to give the proper flash timing with a standard flasher relay resulting a rapid flash (a way to notify drivers that they have a turn indicator bulb thats out). If the original relay (or other similar electromechanical device) was used this would explain your rapid flash problem. I doubt an alternator voltage regulator would be related as that has little to do with turn signal operation (well, not directly). If it is in fact the voltage regulator overdriving your electrical system (putting out excessive voltage) I would highly recommend changing that out as the rapid turn signal flashing would be the least of your worries, as the first thing that comes to mind is overvolting the Engine ECU which is never a good thing. Some have had results wiring in a resistor at each turn signal bulb to fool a standard relay into thinking there is sufficient current draw for normal operation.

Share this post


Link to post
Share on other sites

Does anyone know what this ballast module(25w) part is. It is included in the list of parts required to retrofit the rear LED lights from a MY 06 Exsige/ Elise to the Esprit.

Share this post


Link to post
Share on other sites

The ballast module is there to reduce interference of the radio (mainly on LW stations) every time the lights are illuminated. Not always necesaary and can be fitted on a 'wait and see' basis.

Share this post


Link to post
Share on other sites

You can find these ballast resistors on Ebay for a few quid. Just type in LED bulb resistors. As for fitting them a lot of people make the schollboy error by fitting them in series instead of in parrallel. You fit one wire to the positive side and the other to the negative side, a bit like you are shorting the circuit out. It looks a bit odd but this is the correct way to do it and it works then.

I'll try and sketch something out and post it.

David

PS. If you get stuck finding these resistors then do a seach on this forum for David Hopwood. He can supply them.

Sketch as promised. Sorry it's not very good but I think you'll get the picture.

img092.jpg

Share this post


Link to post
Share on other sites

Ok installed the resisitor and the fast flash is gone. But now when i turn on the headlights you can barely see the lights flashing. Evwerything works until the headlights are on then it shows a very dim flash.

Share this post


Link to post
Share on other sites

88 Esprit NA, 89 Esprit Turbo SE, Evora, Evora S, Evora IPS, Evora S IPS, Evora S IPS SR, Evora 400, Elise S1, Elise S1 111s, Evora GT410 Sport

Evora NA

For forum issues, please contact the Moderators

Share this post


Link to post
Share on other sites

Job done Bibs, thanks.

I do not have the indicator audio tick tick tick now, and the ABS light is still flashing when the side lights are on.

Someone has also kindly bashed my front bumper and cleared off. Just after I had it all fixed and put new Armor Fend on too. Nice!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...