free hit
counters
v8 running rich right bank - Engine/Ancilliaries - The Lotus Forums Jump to content


v8 running rich right bank


Recommended Posts

can anyone help please with this problem, my v8 seems to be running rich in the right bank only this is really noticable at idle but not untill the car starts to warm up the engine then starts to run lumpy faint smoke can be seen from the right exhaust with a strong fuel smell .the plugs were changed 6 months ago along with new coil packs new magnacore leads and two new pre o2 sensors the k&n filters are nowhere near due a clean and re oil.now the confusing bit the yellow dash light has never lit and i recently met up with superdave lotus he did a health check on my car with his odb pc stuff and all appeared ok im all out of idears but am wondering if one of the injectors might be stuffed am i missing somthing or should i just pop the plenum and check this out

Dave Hopwood

Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.
  • Replies 8
  • Created
  • Last Reply

Top Posters In This Topic

*Moved from Events to V8 Tech*

88 Esprit NA, 89 Esprit Turbo SE, Evora, Evora S, Evora IPS, Evora S IPS, Evora S IPS SR, Evora 400, Elise S1, Elise S1 111s, Evora GT410 Sport

Evora NA

For forum issues, please contact the Moderators. I will aim to respond to emails/PM's Mon-Fri 9-6 GMT. 

Link to post
Share on other sites

David:

Just before my #5 injector (US driver's side front) went bad the right bank was running rich to compensate. This was, in my case, due to a short in the wiring that took the #5 injector out, along with a failing idle air control valve and a failing coil pack.

Feff

Link to post
Share on other sites
  • 3 weeks later...

By a dribbling injector I mean one that is leaking fuel and fuel dribbles out of the nozzle even when the injector is supposed to be shut.

S4 Elan, Elan +2S, Federal-spec, World Championship Edition S2 Esprit #42, S1 Elise, Excel SE

 

Link to post
Share on other sites

It turned out to be dodgy lambda sensors. Dave used universal ones instead of the model specific ones. A lesson learned not to cut corners.

Link to post
Share on other sites
David:

Just before my #5 injector (US driver's side front) went bad the right bank was running rich to compensate. This was, in my case, due to a short in the wiring that took the #5 injector out, along with a failing idle air control valve and a failing coil pack.

Feff

Ohhhhhh my dear .... ! :rolleyes: I'm sure this was a true nightmare of a diagnosis job :o

How long did you search/investigate ?

Marcus

Marcus

Link to post
Share on other sites
Ohhhhhh my dear .... ! :rolleyes: I'm sure this was a true nightmare of a diagnosis job :o

How long did you search/investigate ?

Marcus

Hi Marcus this problem took over two weeks of late evenings to sort out because the death light on the dash never lit nor did any fault codes appear,as Dave said you get what you pay for so the originals would probably have been cheaper than the ammount of unburnt shell optimax left on the motorway.Any way plenty more to worry about now,I think my radiators gone(has anyone replaced one without a pit or car hoist ?)

Dave Hopwood

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...