free hit
counters
S2 Stall - Engine/Ancilliaries - The Lotus Forums Jump to content
Sign in to follow this  
GBreadner

S2 Stall

Recommended Posts

Hi Everyone,

I've posted previously regarding the problem I have with my stalling S2 but at the risk of boring everyone could I ask for a bit more advise. Ive noticed that after driving for about 20 mins or so and usually on the over-run as Im coming down to a junction or roundabout I get a single back fire through the exhaust and then the engine dies. It will usually start on the key but has always been problematic starting when hot. Is this air leaking into the carbs ? Any help much appreciated! thanks Gary.

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

Hello,

My car had a crack in the exaust manifold and a combination of a bad fuelpump and carbs not matched together. I bought a new fuelpump, a carbtuner a new exhaust manifold and viola fixed. I have noticed that working with the carbs and learn how they work solve alot of problems. Carbtuner 2 is a great unit.

/Fred

Share this post


Link to post
Share on other sites

For hot starting issues, check the battery/starter earths/connections. Reason is cable impedance increases with temperature.

Good luck

Share this post


Link to post
Share on other sites

has always been problematic starting when hot. Is this air leaking into the carbs ?

All carb'd Esprits had hot starting problems, Lotus even fitted an extractor pump that sucked the hot air out of the air box on the last ones but it had little effect.

I think to sort your problem it's a matter of following the previous advice & checking everything is in proper working order & is properly fitted, or put it into a specialist & get them to take a look. I don't like using garages but there are times when their experience is worth paying for.


Cheers,

John W

http://jonwatkins.co.uk

Share this post


Link to post
Share on other sites

could be this as had same issue after an hour of running when things got hot.

fuel pump on way out not providing fuel hence the spluttering

coil connections - hence the bangs and pops

check the electric lead on the non return value from fuel pump - if dodgy, will shut off fuel

hope helps as gone on this journey myself.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...