free hit
counters
2003 V8 stays at 3000 RPM after hard acceleration - Engine/Ancilliaries - The Lotus Forums Jump to content
icwl

2003 V8 stays at 3000 RPM after hard acceleration

Recommended Posts

During regular driving, my 2003 Esprit runs fine, idling around 900 RPM. If I accelerate quickly through a couple of gears, the car sits at high idle around 2600-3000 RPM. The only way I have found to "fix" this high idle problem is to pull over, turn off the motor and briefly disconnect the battery. Everything is back to normal when restarted. I see some similarities to this problem across the forum but nothing specific to this situation. There is no CEL and my code reader shows no error messages. Any ideas out there?

Much appreciated.

Share this post


Link to post
Share on other sites
Upgrade today to remove Google ads and support TLF.

Idle air control valve I would think. I believe it's a common problem but others more knowledgeable will no doubt be along shortly.

Trevor.

Share this post


Link to post
Share on other sites

My '97 V8 does this about once every 500 miles. It usually rights itself after about 2 minutes and seems to happen more in the summer and when the engine has just been worked a bit. The IAC valve only usually puts the revs up to about 1400, so I would think that is unlikely to be the problem. If disconnecting the battery fixes the problem, it's probably related to the ECU or one of its peripherals. I have always thought that the likely cause of this issue is that the car is so rare and the engine ECU unique that all possible eventualities could not be investigated during development. This means that occasionally, a scenario might arise that is misinterpreted by the ECU and treated as a warm-up situation. Hence the fast idle superimposed on a hot engine.

.....or it could just be a sticking throttle linkage that seizes a little bit more due to the heat!

.....or even a combination of all 3!

Try lubing the linkage. Find a lube spray with PTFE if possible

Share this post


Link to post
Share on other sites

If the throttle linkage is free then the IAC is having problems. If diconnecting the battery stops the problem temporary, that is resetting the entire ECU (sort of). You can reset only the idle "learn" logic by turning the key to "on" not start, and very quickley mash the throttle (full open) 3 times in about 20 seconds, leave the key on for another 1 minute or so. The IAC valve is run in open loop (i.e. the ECU can't tell where it was left.). Resetinng the ECU idle logic, re-synchronizes the ECU and IAC. But you should not have to do this very often, unles the IAC is mis-stepping, which I believe is happening in your case.

Edited by WEllison

Share this post


Link to post
Share on other sites

Thank you for these suggestions. I will start by resetting the ECU idle logic using the process described. If unsuccessful, the IAC may need further investigation. I will report back with results. Much appreciated.

Share this post


Link to post
Share on other sites

Mine did this to me this weekend. I found I could (from a stop), slip the clutch just enough to put load on the engine and the "decay" circuit/sequence woud begin. I have ready many places about the "decay" circuit/program in the ECU. IAC seems a possibility too. I was cruising at 3k-3.5k rpm and frequently passing cars on a 2-lane (running out 2-4 gears). It did it twice, but after a minute or 2 returned to normal. I've got the EEM manual from Lotus - I'll do some bed time reading and maybe find something. The owner's manual does mention the decay circuit/program.

BTW - I also noticed that it was like the throttle was being held open (throttle plate was closing completely so it had to be on the IAC circuit) - however there was not enough fuel being delivered to drive the car - (if I let off the clutch in 1st without using the throttle the car would stall). I winder if it's a cool down, turbo saver sequence....

The one thing I do know is that I don't know......

Share this post


Link to post
Share on other sites

I have just had a thought....Would any harm result if you blocked the IAC pipe where it joins the high pressure duct just before the throttle body. This would mean that if you stiil got your problem, it wouldn't be the IAC and you could find out without needing to take the turtle off which is a pain....especially if you have EGR fitted. Secondly....does the IAC have its own fuse? could it be isolated with the engine at slow idle and therefore would stay shut. I mean, most of the time the IAC is shut and so I can't imagine any problems resulting from temporarily blocking it. You might get a yellow light but this would self cancel after restoring the system. My IAC tube blew off once when the red pipe became disconnected from the boost controller and the engine was overboosting. Apart from going like a Diablo on steroids, no harm resulted.

Share this post


Link to post
Share on other sites

I have reset the ECU and drove 20 minutes to (hopefully) reprogram the logic. I will go for a spirited run this weekend (great weather ahead for Ottawa) and report back. Thank you everyone to date with your suggestions. I will take this one step at a time. Cheers.

Share this post


Link to post
Share on other sites

I am not sure the engine would even run with the idle air source blocked. There is no provision to mechanically set an idle screw. I guess you could add a temporary shim or just hold the throttle open as a test, it would be a challange to drive! The IAC is typically about 30% open with no command from the ECU.

Edited by WEllison

Share this post


Link to post
Share on other sites

We know 'preload' on the throttle flap is set up mechanically (in correspondence with the cable from the pedal..) -there is a bracket on the throttle body endstop too.. but if you block the IAC hose and lift up the throttle 'manually' instead it gives a %-reading on the *Throttle position* parameter as result, without all the others like IAC- 'pulse voltge' (%) in correspondance -right?

Could't this irritate the Engine control even more ?

*page16/section ED (page 486ff in the pdf-versions) gives a good overview on what could all go wrong on othe possible points -there are gaskets on the different layers of the throttle body/EGR body itself ..so if a garage without knowledge about the details tried to undo the plenum on those nuts & bolds ..maybe just an airleak on a broken gasket is the result ?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...