free hit
counters
V8 Oil Pressure again............... - Engine/Ancilliaries - The Lotus Forums Jump to content
Sign in to follow this  
silver bullet

V8 Oil Pressure again...............

Recommended Posts

Hi all

Recently posted regarding the issue of my oil pressure dropping at idle due debris from a broken oil pick up jamming the pressure release valve.

Engine out, problem solved & a new pick up installed.....

Done two thousand miles since & all has been fine........Until yesterday i put my foot in hard in third & as fast as the boost needle rises, the oil pressure sinks into the red..............Back off the throttle & the oil pressure goes back to a 2/3 bar.....................On idle the needle rests as it should at 1.4bar.

This is driving me crazy. because it means either a faulty sender/electrical problem or a main bearings/shells job.

She doesnt smoke,sound rough or anything to suggest a big problem.

Has anyone had anything remotley similar??...............It may just be a faulty sender but i wont hold my breath.....

Any input is appreciated

I wish lotus done a quick release engine kit as mine has been lifted out twice in just over a year now!

Ps - Tried an oil change & a new filter.........no change

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

sorry to hear about the problems...quite a heart wrenching situation. I spoke to my specialist about it with the detail as per your post. Unfortunately he said that it could be a number of things and a proper diagnosis is required here before further work. How are you measuring the oil pressure?

Share this post


Link to post
Share on other sites
sorry to hear about the problems...quite a heart wrenching situation. I spoke to my specialist about it with the detail as per your post. Unfortunately he said that it could be a number of things and a proper diagnosis is required here before further work. How are you measuring the oil pressure?

Hi there & thanks for your reply

I have a friend who has a V8 aswell, we swapped the oil pressure sender unit & the oil pressure was fine!!

Bought a new unit from e bay & i'm away............Just over 4 bar when cold & when she's hot & comes on boost, the pressure goes up!!

Now i'm a happy man!!..............The engine stays in ---- although lotus should have put the V8 in with velcro based on how hard everything is to do!!! :D

Share this post


Link to post
Share on other sites
Hi there & thanks for your reply

I have a friend who has a V8 aswell, we swapped the oil pressure sender unit & the oil pressure was fine!!

Bought a new unit from e bay & i'm away............Just over 4 bar when cold & when she's hot & comes on boost, the pressure goes up!!

Now i'm a happy man!!..............The engine stays in ---- although lotus should have put the V8 in with velcro based on how hard everything is to do!!! :D

Did you use anything to "seal" the threads on the oil sender unit when you installed it?

JoeyO

Edited by joeyoesprit

JoeyO

2001 V8 - Silver

2007 Ducati 1098

Share this post


Link to post
Share on other sites

Hi.

No it just bolted sraight up,got just over 4 bar now

Think its worth while changing it because the diphram inside splits & shows less pressure over a period of time, with the new item the needle just bangs straight up there

regards

alex

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...