free hit
counters
Switching headlights from Continent settings to UK - Interior/Exterior/Lights/Glass/Alarms/ICE/HVAC/Other - The Lotus Forums Jump to content
Sven76

Switching headlights from Continent settings to UK

Recommended Posts

Any idea how to do this on the Evora? Handbook stays silent, dealer no idea and the standard stickers put onto the lights don't work with the Evora design I guess.

Coming to Scotland in 2 weeks and don't want to upset oncoming traffic.

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

Hi Sven

I was unable to switch my lights for continental driving when I took my Evora to Switzerland in 2010 but I did manage to mask the beam so it didn't dazzle oncoming cars. I bought my beam deflectors on the ferry crossing and you can see from the photograph the position I had to stick them.

I will have another look at your itinerary and see if there is a suitable meet up point.

Brian

post-225-0-44710900-1367679134.jpg

Share this post


Link to post
Share on other sites

Brian, how have you figured out the position? And have you been on the Newcastle - Amsterdam ferry?

Share this post


Link to post
Share on other sites

I am sure that the instructions show which part of the projector lens has to be covered. It seemed to work as no one flashed me.

The position will obviously be different on a LHD car. I am not at home just now but will check to see if I still have the instructions and will scan a copy and post up here.

Yes I have been on the Newcastle-Amsterdam ferry, both ways and I am sure I bought them on that ferry.

Share this post


Link to post
Share on other sites

Perfect, we're on the same ferry, so I can get it there. Wonder that you have done both sides, would have thought that for a RHD you do the left side only (and LHD vice versa).

Share this post


Link to post
Share on other sites

Did Lotus themselves have a view on what to do? It's a shame that there does not appear to be an adjustment rather than a sticker

Share this post


Link to post
Share on other sites

No, have checked with my garage, no quick fix.

Also forgot to buy the stickers, worked ok for 2 weeks, no flashing from others.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×