free hit
counters
V8 engine takes ages to start - Engine/Ancilliaries - The Lotus Forums Jump to content
Sign in to follow this  
Tonytrees710

V8 engine takes ages to start

Recommended Posts

Hi folks

 

My V8 has been in storage for the last 6 years. I'm now intending to use it, but it takes an age to start - this was a problem I had before storage, so need to get it sorted. I've got a brand new battery, but the engine seems to turn over a hell of a lot before firing up.

 

Any ideas?

 

Cheers

 

Tony

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

They aren't quick starters at the best of times, how long are you talking Tony?

Share this post


Link to post
Share on other sites

i had the same with mine if its stood for a while the hydraulic buckets will have drained so there will be no oil helping the valves creating low compression i got round this by removing the spark plugs and squirting a bit of mobile 1 into the top of the piston uping the compression it smokes for a while then clears but should help

Share this post


Link to post
Share on other sites

My guess would be low fuel pressure. Have you tried leaving the ignition on for 15 seconds while the system primes and see if that makes a difference? That may be an indication?

Trevor.

Share this post


Link to post
Share on other sites

My guess would be low fuel pressure. Have you tried leaving the ignition on for 15 seconds while the system primes and see if that makes a difference? That may be an indication?

Trevor.

Thanks Trevor - I left it longer before starting and she starts straight away - well pleased.

 

Regards

 

Tony

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


×