free hit
counters
Intermittent Turbo boost - Induction/Turbo/Chargecooler/Manifold/Exhaust - The Lotus Forums Jump to content
Sign in to follow this  
David Parker

Intermittent Turbo boost

Recommended Posts

Hi all, first post here and I have already found loads of useful info so thanks in advance.

My 1989 SE is having intermittent turbo issues, sometimes I will get the full on slammed in the seat boost, other times I will be lucky to get 0.5 bar and hardly any boost at all.

After reading through the forums I now know that I probably have a knackered chargecooler impeller, the top of the cooler is always hot and from what I have read this is a sure sign that the impeller has gone. However, would this cause an intermittent boost? The other thing I have noticed recently is that the water warning light is constantly on (the orange one at the far top right of the dash) even though the water levels are fine.

All of this started after I had a load of repair work done (snapped final drive shaft), got the car back, foolishly didn't check it all out and then garaged her for 6 months. Once I went to drive it again the catalogue of omissions that the "garage" had made was staggering. Handbrake not reconnected, reverse lights not connected, exhaust back pressure valve not connected and the vacuum pipe left trapped between 2 body panels, diff shaft oil leak etc, etc. I have cured all of those but can not get my head around the erratic turbo power, could the soon to be replaced impeller be causing the power drop off and warning light?

Best Regards

Dave

Share this post


Link to post
Share on other sites
Upgrade today to remove Google ads and support TLF.

The turbo problem could be a vacuum hose issue, possibly not reconnected properly after all the work done. The water warning light could simply be the connector at the bottom of the header tank or the connector at the thermostat housing.

 

Not surprising to hear about the problems after car had been worked on by idiots who call themselves mechanics. Over the weekend we were changing cambelts and one Esprit had been fitted with wrong belt that looked like it had been purchased from ebay and a tensioner incorrectly fitted. When running you could see the belt jumping up and down on the pulleys.

 

If I were you before making a judgement about the turbo check out all the connectors etc.  

Share this post


Link to post
Share on other sites

A bad intercooler will restrict power, but will not restrict boost, unless the ECU detects a knock condition along with the extra heat in the system.

 

It seems a lot of these cars are starting to have fuel pump issues, and that is showing up as a boost limit after the ECU senses a lean condition.  With no check engine codes thrown in many cases.

Share this post


Link to post
Share on other sites

Is the water temp over 85 degrees? You'll only get 0.65 bar if it's not a full temp. 

 

You can suss if the chargecooler impellor is knackered by touching the chargecooler body after a run. It should feel as cool as a beer from the fridge. Definitely upgrade (£100) to an electric pump, it's a no brainer. A non-functioning chargecooler will manifest itself with poor sustained boost, you'll see it drop as the MAT increases to huge numbers at the end of some hard acceleration. 

Share this post


Link to post
Share on other sites

Thanks for the responses so far, very informative.

You just may have something there Bibs, I haven't actually looked at the temperature gauge when it has been doing it. i don't ever give her full welly when she is cold, but it could be that I was maybe being a bit "over eager" and hadn't let her warm up to full temperature, I will have a look at that tomorrow.

The chargecooler impeller has definitely had it, the top of the box is at the same temperature as the rest of the engine after a run so I know it is doing sweet FA, I have looked around briefly at the electric kits but can't seem to find one that has everything, i.e. the kit, gaskets, blanking plates etc, maybe one of you gents could point me in the direction of a full kit and some instructions.

Regards

Dave

Share this post


Link to post
Share on other sites

There are not any "Full Kits" which include everything.. have to put together yourself...

Share this post


Link to post
Share on other sites

You only need the electric pump and a couple of feet of wire really. You don't need a blanking plate for the old pump, you can remove it and empty what's left of the impellor then replace it. 

Share this post


Link to post
Share on other sites

Thoroughly flush the header tank, take it off and flush it. If it slushy, rusty at the bottom, and your car is the right vintage for it to be so, that's where your electrical connections are. May as well flush the rest of it while your there, unless it's been done in the last year or so.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


×