free hit
counters
Chargecooler pump pipe routing - Induction/Turbo/Chargecooler/Manifold/Exhaust - The Lotus Forums - Lotus Community Partner #ForTheOwners Jump to content


IGNORED

Chargecooler pump pipe routing


Recommended Posts

Hello,

 

I have a 1989 Esprit Turbo Chargecooled project car.  It came in bits and I am slowly assembling.  I have replaced the Chargecooler pump seals, but the hose connections are confusing me.  There is a twisted hose connected to the pump inlet at one end (its like a pigs tail), and the other end of the hose points straight at the hole in the inlet plenum,  where I believe the temperature transducer should go. There is nothing in the hole at the moment, so I don't know if this is a later modification to the common cooling circuit type and I should connect the pump inlet there, and if so where does the temp sensor go?  I have only one header tank which suggests that it could be the common system type.  If that is the case, where do I connect the outlet from the chargecooler box to ??

 

Any help gratefully received

 

Alan

Link to comment
Share on other sites


Upgrade today to remove Google ads and support TLF.
  • Replies 15
  • Created
  • Last Reply

Top Posters In This Topic

If you want the best piece of advice I can give on the subject of the CC pump, it's dump it. Blank it off and swap to an electric one, the impellers of the original type fail very soon into their use.

 

If you want to keep using the original, yes it's a common system. You need to have the coll water going into the bottom of the chargecooler, the hot water coming out of the top of the CC and going to the CC rad at the front of the car. Does that give enough info to plumb it in?

Link to comment
Share on other sites

Andy

 

Many thanks for your help.

 

So I connect the outlet from the chargecooler plenum through to the radiator and the return from the radiator to the pump inlet.  The pump outlet then goes to the Cjaregcooler plenum inlet.  Somewhere there is a connection to the normal cooling system head tank?

 

I'm still a bit puzzled by my 'pig tail' hose, however............

 

Alan

Link to comment
Share on other sites

not finding anything.

 

After you upload an image it'll give you a link to a blahblah.jpg.  Copy that and paste it here.

 

After reading this ;)

http://www.thelotusforums.com/forums/topic/32256-help-i-cant-post-an-image-or-video-to-the-forum/

Travis

Vulcan Grey 89SE

 

Link to comment
Share on other sites

Odd.  that is an old manifold, not an SE.

 

The SE and later have a coolant temperature sensor for the ECU in the intake manifold (normally perpendicular to that hole though).

 

So you'll need a sensor there to plug that so all the water doesn't run out...  I assume the car has not been run yet?

 

The charge cooler pump inlet hose should connect to the Tee under the coolant header tanks as the diagrams above show.


actually looking closely... It looks like you have the Auxiliary Idle Air Bypass hose connected to the charger cooler water pump....

 

This hose

IMG_2596.JPG

 

Is supposed to go here where this blue hose is.

IMG_2727.JPG

IMG_2728.JPG

Travis

Vulcan Grey 89SE

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.



Upgrade today to remove Google ads and support TLF.


×
×
  • Create New...