free hit
counters
Fuses way different from the service manual - Interior/Exterior/Lights/Glass/ICE/HVAC & Other - The Lotus Forums Jump to content
soldave

Fuses way different from the service manual

Recommended Posts

Just been doing a bit of electrics work on my Eclat and noticed the fuses that were in my engine bay are way different from what the service manual states they should be.  They looked like this picture below:

post-17588-0-50205300-1412891570.jpg 

 

To reiterate, that's 8A, 8A, 8A, 25A, 16A, 16A, 16A.

 

I rearranged the fuses to look like the service manual states, as you can see below:

post-17588-0-47205800-1412891571.jpg

 

Andthat's 16A, 8A, 8A, 25A, 25A, 16A, 16A.

 

But then the fuse cover looks like this:

post-17588-0-07110100-1412891572.jpg

 

Is how I've got my fuses set now (as in the 2nd picture) how things should be, or should I go back to that first picture layout?

Share this post


Link to post
Share on other sites
Upgrade today to remove Google ads and support TLF.

That fuse cover might be off a different car, mine is black and is as per your 16A, 8A, 8A, 25A, 25A, 16A, 16A. is what I have, I'll double check tonight.

Edited by CharlieCroker

Share this post


Link to post
Share on other sites

Thanks.  Will see if I can source an original cover too (will add it to "the list"!).

Share this post


Link to post
Share on other sites

20140427_122201_zps964ba40f.jpg

 

I knew I had a photo somewhere of my fuse box cover, hopefully this will help?

Share this post


Link to post
Share on other sites

Oooohhh, look at this fancy man with his fuse box cover ;)

 

Confirms what I was thinking, so many thanks for that.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×