free hit
counters
slightly high idle - Engine/Ancilliaries - The Lotus Forums Jump to content


Recommended Posts

hey guys, my car has always idled at 900-1000rpm but ever since i had my fuel tanks replaced with aluminium ones with new fuel pump, the water pump rebuilt and the temp gauge sender replaced it runns at 1200...the throttle cable doesnt seem tight etc....throttle jack, when activated doesnt even touch the throttle so it aint the throttle jack....weird...

Link to post
Share on other sites
  • 1 year later...

Upgrade today to remove Google ads and support TLF.
  • Replies 2
  • Created
  • Last Reply

Top Posters In This Topic

~1200 is normal for an idle when the engine is cold (on the DELCO injected Esprits 89+), then it should settle to about 980rpm.

Does yours do it only when cold?

It could be a slightly tight throttle cable, I have to set them with slack when the engine is fully warmed (and still allow 0%-100% on the DELCO cars).

It could be an air leak in the manifold.

The throttle jack mechanism can stick and pin the throttle butterflies open a bit at times.

Travis

Vulcan Grey 89SE

My Lotus Photo and Projects Album

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...