free hit
counters
Exige s2 dash not lighting up - Interior/Exterior/Lights/Glass/Alarms/ICE/HVAC/Other - The Lotus Forums Jump to content
Sign in to follow this  
Jossm

Exige s2 dash not lighting up

Recommended Posts

My 2008 exige s2 dash isn't lighting up, the lcd display is working correctly and dims when the lights are switched on but the White speedo/rev counter doesn't light up. It's the updated dash, black dash with white backlighting. Hopefully someone can help?

Cheers Joss

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

Sorry to point out the obvious but is the bulb blown?

Share this post


Link to post
Share on other sites

No your right to point out the obvious, but I presume there are loads of small LEDs soldered onto a printed circuit board like most modern cars, so it's not just a case of changing a bulb.i may need a whole new dash.. Just trying to find out if anyone else has had this problem before. Thanks

Share this post


Link to post
Share on other sites

The dash brightness is adjustable and does go all the way down to off.

Read the manual or hold the trip reset button when showing kph should do it?

Share this post


Link to post
Share on other sites

Thanks, it's fixed haha. I never knew it done that. I don't even know how it manged to change because I never press that button. Anyway it's been fixed for free.

Cheers Joss

  • Like 2

Share this post


Link to post
Share on other sites

Great news! :thumbsup:  I always turn mine down as on full it's far too bright.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


×