free hit
counters
Baro sensor voltage in freescan - ECU/Freescan/Espritmon - The Lotus Forums Jump to content
Peteric

Baro sensor voltage in freescan

Recommended Posts

Hi Everyone

Had the plate with map sensor and baro out of the car to make sure pipe/elbow on Map sensor was secure and not worn/leaking air.

I thought i would check the sensor voltage values while i had the sensors there by using a vacuum pump and freescan as in EMH 3 page 5 and 6 in the manual just to make sure all was ok.

Map sensor was all ok but the Baro sensor voltages were completely wrong, about half of what manual says they should be (manual says they should approx be twice the amount of the Map sensor).

This is what the Lotus manual says the Baro sensor should read:

0 kpa - 4.7 to 4.9 volts

20kpa - 3.2 to 3.4 volts

40kpa - 2.1 to 2.3 volts

60kpa - 1.0 to 1.2 volts

So I thought that my sensor was shot however on page 14 of the freescan manual it shows the screenshot of sensor voltage screen with Baro showing scaled value of 0.840 and voltage of 2.24 volts which is exactly in line with what mine reads in freescan.

So questions are

1) are the Baro sensor voltage readings in freescan incorrect?

2) is the lotus manual incorrect in saying the baro voltage should be approx twice the voltage of map voltage?

3) has anyone else done this test with the vacuum pump on the Baro sensor with freescan and what were your findings?

Peter

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

Is it any better in espritmon ??

Share this post


Link to post
Share on other sites

Thanks for that Derek.

I did try Espritmon (nice program) but I don't think it displays the Baro sensors voltage required for the test in the workshop manual.

I like the idea of tuner pro but don't you need an xdf file of a similar EFI system to import into the software or can you make your own? I'm confused on that one.

Share this post


Link to post
Share on other sites

There is an adx already available for TunerPro but you can make your own if you wish.

Share this post


Link to post
Share on other sites

I don't know if I would make one myself as I don't really know what is involved! I do see after further investigation that there is an adx on the tuner pro website so thanks for the pointer.

I only want to monitor data from the engine for fault finding.

Share this post


Link to post
Share on other sites

Thanks for that Derek.

I did try Espritmon (nice program) but I don't think it displays the Baro sensors voltage required for the test in the workshop manual.

I like the idea of tuner pro but don't you need an xdf file of a similar EFI system to import into the software or can you make your own? I'm confused on that one.

Indeed Espritmon converts the value and does not display the voltage itself. Good idea to also display the raw value, will see when I have time to implement this.

Regarding the baro value itself, the correct translation is performed, I will need to dig-up the sensor spec and characteristic but this has been a topic of discussion in the past so there should be more info in another thread.

 

Erik

Share this post


Link to post
Share on other sites

I just looked up how I did it years ago in Espritmon.

The spec of the GM 16009886 - 2Bar MAP Sensor says: Vout=Vref(P/2-0.04) with P in bar.

In de mode1 data, the voltage is represented by a single byte (hence 0 to 255) and Vref is 5V.

The equation in Espritmon to display MAP is n*2/255+0.08 with n=0 for Voltage=0 and n=255 for Voltage=5 V

I added a Voltage readout in the MAP graph, will update the downloadable archive in the coming days.

Good luck,

 

Erik

  • Like 1

Share this post


Link to post
Share on other sites

I just updated the version that can be downloaded. It displays the voltage for baro and MAP.

 

Erik

Share this post


Link to post
Share on other sites

Indeed!

Its people like Erik that help us keep these beautiful cars on the road!

Well done Erik!

Share this post


Link to post
Share on other sites

Hi Erik

Is your site down? I cant seem to connect to it to download the new version.

Peter

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×