free hit
counters
Unwanted noises - Engine/Ancilliaries - The Lotus Forums Jump to content


Recommended Posts

HELP,

I have an 88 carb turbo and its not sounding healthy.

After a long run (when everything is nice and hot) on turning the engine off there is a delay of approx 6 secs and then a large pop sound. Its not quite a backfire but its not exactly attractive. There's also a hint of popping on the fall down whilst driving. Replaced the ignition pick off, distributor, HT leads, spark plugs. Had the compression checked, carbs tuned and balenced up by reputable lotus dealer and still no joy. Can anyone shed any light on this problem? It sounds very similar to when my exhaust manifold died but i'm told it cant be the rest of the exhaust even though its not been replaced for the life of the car at 74000 miles. Please help to get esprit purring again as its dammed embarassing having it cough and complain all the time. :ph34r:

Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.
  • Replies 6
  • Created
  • Last Reply

Top Posters In This Topic

After a long run (when everything is nice and hot) on turning the engine off there is a delay of approx 6 secs and then a large pop sound. Its not quite a backfire but its not exactly attractive. There's also a hint of popping on the fall down whilst driving. Replaced the ignition pick off, distributor, HT leads, spark plugs. Had the compression checked, carbs tuned and balenced up by reputable lotus dealer and still no joy.
Edited by CarBuff

Atwell Haines

'88 Esprit

Succasunna, NJ USA

Link to post
Share on other sites

thanks for all the info guys, as wayne says there is no cat on my motor and the compression check should have shown up an exhaust valve. It was running a little rich but this was sorted by the tune up done by lotus. Looks like i'm gonna have to bite the bullet and just replace the exhaust system. Just got to find a decent stainless steel system now, that doesn't make the car look and sound to much like a boy racer. It'll be cheaper than messing with the head and valves!!! Cheers chris

Link to post
Share on other sites
  • 6 months later...
thanks for all the info guys, as wayne says there is no cat on my motor and the compression check should have shown up an exhaust valve. It was running a little rich but this was sorted by the tune up done by lotus. Looks like i'm gonna have to bite the bullet and just replace the exhaust system. Just got to find a decent stainless steel system now, that doesn't make the car look and sound to much like a boy racer. It'll be cheaper than messing with the head and valves!!! Cheers chris

<{POST_SNAPBACK}>

last update: wasnt any of the above!!!

Turned out to be ignition timing causing the problems coupled with a cambelt that wasn't quite fitted right. luckily no damage done however not impressed with nick whale lotus in bromsgrove as it went to them to check both valve and ignition timing and was reported to be good. All I can assume is the mechanic was blind and it was the dogs day off!!!

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...