free hit
counters
'95 S4 Brake Problems Solved - Misc including parts cross references - The Lotus Forums Jump to content


Recommended Posts

I have seen a few threads about brake problems so I thought I'd provide a detailed explanation of the symptoms the car exhibited and the fix as I imagine others might have the same issue in the future.

Before I bought the car I noticed that it had a flashing ABS light, the brake pedal pushed back against my foot and sort of modulated in and out in a 2 second period, and there was about a one second delay between when I pushed the pedal and when the car actually began to stop (something quite terrifying at times).

I had the PO replace the ABS accumulator and that cured the ABS light. Others on this board said the "push back" feeling was normal, so I bought the car and accepted it as a Lotus quirk. After a week, I couldn't stand it anymore so I took the car to "Foreign Toys" in Ft. Lauderdale. They found that the system was only making 1800psi rather than the (I believe) 2800psi it was supposed to.

After trying a different pressure switch with no success they thought the brake system was bad so I debated buying a used unit for $800 or paying $780 to have Prior Remanufacturing try to rebuild it. Before he removed it, Paul (the owner of the shop) pulled the cap off the fluid reservoir and noticed that the fluid was NOT DOT4, but some sort of Jaguar fluid. In the course of the service he also found that the thermostat had a hole drilled in it so the PO's mechanic wasn't exactly ready for F1 pit duties.

After flushing the system with DOT4 fluid and replacing three damaged seals in the master cylinder, the brakes feel much better. Apparently, the bad fluid had damaged the seals, and the fluid was travelling in a loop from the pump past the seals and back again, cauing the modulating feeling.

The brakes now have no delay between pedal depression and stopping power. The pedal does still "push back" but only once at the beginning of brake application. I will also install the revised pressure switch eventually which will hopefully make for a completely normal brake feeling.

Hopefully this can serve as a "search" resource to others who might have brakes that feel like something ghostly has posessed the system!

Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.
  • Replies 4
  • Created
  • Last Reply

Top Posters In This Topic

Top Posters In This Topic

Popular Posts

Hi All.  Resurrecting this post from over a decade ago.  I had the EXACT same problem happen to me again.  This time Flow Lotus in Winston-Salem put the wrong brake fluid in the car (even though I gav

I am awaiting the replacement of the switch as well. Some time in this month I ought to get the switch.

I talked to my shop and the guy said that the pumping feeling would still be there. He sais that he got rid of his "pumping" after installing 320mm disks to go with his AP's, but I just can not seem to follow that thought just from the logics of the system. :lol:

Anyway nex year, or in fall, I will go for the AP's and will be able to tell. :D

Olaf S400 project www.esprits4.de

__________________________________

shapeimage_1.jpg

Link to post
Share on other sites

i have a partly related problem on my s4s.

When i turn on my ignition the abs light sometimes stays on and sometimes goes off.The brake pedal constantly has a long travel to begin with and after 10 minutes of driving and braking the pedal rises to where it should be effective and is nice and hard.I replaced the pressure switch a couple of months ago and have fiddled with the brake pedal switch which was loose and tending to keep my brake lights on.So realy my main problem is the long travel of the pedal when i first drive the car in the morning.

Any suggestions?

Link to post
Share on other sites
  • 13 years later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...