free hit
counters
New lotech suspension, now brakes pull right - Suspension/Brakes/Wheels/Hubs/Steering/Geo - The Lotus Forums Jump to content


New lotech suspension, now brakes pull right


Recommended Posts

Just installed lotech suspension all around. On test drive had virtually no pedal ( read goes slowly to floor like bleeder was partly open). Of course this was a surprise while driving, so when pressed pedal again, had more brake, but pulled hard to right. Car will stop if pumped, but looses pressure. No visible leaks, nothing brake related touched while doing suspension. Only upper a arms, and sway bar loosened/moved. Hub with caliper may have moved lines but nothing bad, or am I missing something. Master cylinder is full and appears clean. No issues before I messed with springs and dampers. Car did start test drive off just fine.

Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.
  • Replies 5
  • Created
  • Last Reply

Top Posters In This Topic

  • 11 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...