free hit
counters
Help, broken down. - Engine/Ancilliaries - The Lotus Forums #ForTheOwners Jump to content


Help, broken down.


markw996

Recommended Posts

So I've just changed by front suspension and sticky brake caliper, decided to go for a test drive and I'm now waiting for the AA about 3 miles from home.

I haven't disturbed anything I shouldn't have, but it has been up and down ramps a few times so maybe it's sucked up some muck from the tank.

It will start but won't tick over for more than a second or two. I can keep it running by pressing the throttle furiously but it won't rev past 1500 and cuts out as soon as I stop.

I'm booked in for an MOT retest on Tuesday and really want to get to the festival at Brands this weekend.

Any ideas?

1994 Lotus Esprit S4  &  2016 Tesla Model S P90D

Link to comment
Share on other sites


Upgrade today to remove Google ads and support TLF.

Vacuum leak/s? Those rubber elbows perish by just looking at them. Had the same once on a friends GT3 after we did a clutch on it and turned out to be an elbow around the map sensor. We replaced them all as matter of course and was spot on after that.

  • Like 1

1982 DeLorean DMC 12 #16327, 1999 Lotus Elise, 1998 Lotus Esprit GT3 #2272, 2011 Lotus Evora S, 2013 Lotus Exige S,2016 Lotus Evora 400

Link to comment
Share on other sites

Check the inertia switch in the fuel pump circuit...both that it's on and that the wiring is plugged in properly.

  • Like 1

Scientists investigate that which already is; Engineers create that which has never been." - Albert Einstein

Link to comment
Share on other sites

Always the simplest things......we've all been there (or else are going to be!) Glad all's well now....

  • Like 1

Scientists investigate that which already is; Engineers create that which has never been." - Albert Einstein

Link to comment
Share on other sites

41 minutes ago, internets said:

Vacuum leak/s? Those rubber elbows perish by just looking at them. Had the same once on a friends GT3 after we did a clutch on it and turned out to be an elbow around the map sensor. We replaced them all as matter of course and was spot on after that.

Thanks Chris, I replaced all the vacuum lines & elbows when I first got the car in 2013.

See above for the erm.... fix :blush:

  • Like 1

1994 Lotus Esprit S4  &  2016 Tesla Model S P90D

Link to comment
Share on other sites

  • 2 weeks later...

Mark if you get any problems in the near future such as car stuttering under load  et,c go to the fuel pump i  found out the hard way the pumps don't like being run without cooling from the fuel ! (as i was a tight arse and ran the car pretty low on fuel)

Nick S4s

Simplest things first.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...