free hit
counters
Front bonnet no longer "latches" - Interior/Exterior/Lights/Glass/Alarms/ICE/HVAC - The Lotus Forums Jump to content
Techspy

Front bonnet no longer "latches"

Recommended Posts

So I push the front bonnet latch handle forward to allow the latch disc to capture the striker. Then I pull it back to latch it but it no longer has that positive "catch" or snap and just springs back forward and I can still pull the bonnet up by hand. I have explored under the driver side and see nothing interfering. Also checked the mechanisms under the bonnet and can't find anything amiss. I also checked under the passenger side but it is more difficult to see all the points in question. But, nothing has changed under the dash or anything related to this since it last worked. Any ideas? Is the "snap" a result of the "rod bonnet lock" bend getting wrapped around the shaft?

Thanks

Share this post


Link to post
Share on other sites
Upgrade today to remove Google ads and support TLF.

Hi 

i had a similar problem some years ago.  Carefully check the plastic end clips where the metal rod links into position, under the dash.  Mine had gone brittle and had broken off.

Cheers

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...