free hit
counters
350 Sport Battery - Engine & Ancillaries/Gearbox - The Lotus Forums Jump to content
Cads

350 Sport Battery

Recommended Posts

Hi guys -

I've read the previous battery threads, but just wondering if anyone has recently replaced theirs.

Ive got a Jan 2017 car and the battery is already knackered, so I need something abit better than the factory spec I think.  It's started draining even after a decent run (like today, when I got stranded at Oulton Park!!).  

I also have a tracker fitted to the car which isnt helping.

So far the best I can find is a Bosch S4.... Has anyone got any other reccomedations or ideas?  

 

 

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

Mine is a March ‘16, lives outside, does an irregular urban commute of 5 miles all year round, has a non-insurance tracker and my battery is fine (so far).

You sure you haven’t got another problem draining yours?

Share this post


Link to post
Share on other sites

I’m assuming its a faulty battery just because I can have it on the CTEC for 5 day’s, but even then it struggles to turn the car over and the dials flick right to left... (like when it’s flat) and there’s small delay in lighting the instrument panel up.

If I turn it off I get one or two more starts then it’s dead... 

Feels to me like it’s not holding it’s charge... 

Im not sure what else could be draining it?

 

Share this post


Link to post
Share on other sites

I have a standard Varta battery available if you're interested. Only came out my car as the CupR aerokit comes with a smaller battery to clear the  chassis mounts for the rear wing. The battery was always on a conditioner and never gave any trouble. 

Share this post


Link to post
Share on other sites

Thanks @Arun_D.

I might be interested in that, however @KJD might have a point about something draining the battery.  I've read some other threads and asked about abit and it sounds like it might have another issue...

I've got it booked in next week, let me see what they say and I'll come back to you if it is just the battery!

 

Share this post


Link to post
Share on other sites

Indeed, that definitely needs looking at. Let me know, it'll definitely be of use to me if I can clear it out the garage!

Edited by Bravo73

Share this post


Link to post
Share on other sites

My original battery died when only 6 months old, car is plugged into the CTEK whenever Not being used for a few days. Think Lotus  fitted rubbish batteries at the time.

Discovered the battery was dead on the morning of a 1000 mile road trip, the little lithium booster pack I’d just bought saved me, I thoroughly recommend them. Replacement battery I got is nothing fancy, whatever was on the shelf, but it’s been faultless. 

Share this post


Link to post
Share on other sites

Thanks @NickEng, I hope that’s all mine is as well... it certainly feels like it. I’ve got the spanner 🔧 on the dash as well though so I think I have another issue - although potentially not related to the electrics or battery! 

 

Do you mind me asking which lithium power pack you went for @NickEng? They sound like they could be useful...

 

Edited by Cads

Share this post


Link to post
Share on other sites

I bought one off amazon called ‘Guluman’, it’s worked perfectly for me but isn't the nicest when it comes to design and quality. Since then I’ve used a few different ones, I recommend the ones from ‘NOCO’. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...