free hit
counters
Sorry not lotus related ... - Lotus / Motoring / Cars Chat - The Lotus Forums - Official Lotus Community Partner Jump to content


IGNORED

Sorry not lotus related ...


Recommended Posts

Hi all .Just after some advice .Marcos 1600 ford cross flow engine .Could a car alarm .cause a weak spark on ignition .Reason car will not run on choke .But will run better on the throttle .we changed the distributter over to a points one .Car ran a little cleaner .on remote starter switch .mate thinks it's got a weak spark .plugs changed .carb getting plenty of fuel .luminition fitted .Clifford concept 300 system fitted since 2003 .mate thinks the alarm could be the cause .?Soory if it's in the wrong section ....Mike

Link to comment
Share on other sites


Upgrade today to remove Google ads and support TLF.
  • Replies 8
  • Created
  • Last Reply

Top Posters In This Topic

Popular Days

  • Gold FFM

Mike, as long as there's a good earth, there's no way an alarm is causing that.  Ignition timing and advance correct? CO adjusted correctly? Choke adjusted correctly?  Change the choke setup to increase engine speed.

British Fart to Florida, Nude to New York, Dunce to Denmark, Numpty to Newfoundland.  And Shitfaced Silly Sod to Sweden.

Link to comment
Share on other sites

Have you checked if it’s got above 12v going to the coil? Sometimes the coils struggle to take and transfer the voltage/ampage when they get old.

Link to comment
Share on other sites

ZOk guys thanks for the replies .car has a twin choke Webber fitted Spanish built .getting enough fuel .I will check what the coil is getting .it has the ballest resister fitted ..looked on eBay same resisters fitted supplied with luminition coil .Was going to take it to a local garage but have to wait for approx 2 mounths .tipton garage .The owner was I think a member of Jack Brabbom f1 years back .Thanks Mike

Link to comment
Share on other sites

If you think it's weak spark, then check strength of the spark. There are simple tools where you can vary the air-gap to check that it can jump it (or not).  If it's a decent spark the you can stop chasing that wild goose (and start on others).

Link to comment
Share on other sites

Yes .i agree Steve ..The previous owner had problems saying he thought it never ran as good as it should .it just ran a little better cleaner when we put  the points dissy in .trying to bypass  ingnition system on. The car .operarated on a switch from starter motor ..Thanks for all the replies .Mike

Link to comment
Share on other sites

Maybe look at at a carb rebuild kit Mike,  very cheap to purchase and just use brake cleaner to clean the parts when stripped down.  just strip it down slowly and keep in mythodical order.   Well worth doing to rule it out,   Carb may be getting plenty of fuel but does not mean it is distributing it properly.  May explain why it runs well on full throttle but not on idle.  

 

A

Link to comment
Share on other sites

Thanks Dan .its a brand new Webber carb .As I said Spanish built .ok .....it's got to be fuel related or ingnition .....As my mate said simple engine.....He has one in a jago jeep .....Mike

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.




×
×
  • Create New...