free hit
counters
I think I am missing an adaptor between throttle spindle and tps. - Induction/Turbo/Chargecooler/Manifold/Exhaust - The Lotus Forums Jump to content
alzmoore

I think I am missing an adaptor between throttle spindle and tps.

Recommended Posts

Hello,  I've finally managed  to get back to my 1989 SE project..  I can't get the tps to align properly with the screw holes on the end of the throttle bodies and get the right voltage and my mate is convinced that there is an adaptor missing from the end of the throttle spindle.  The shaft end is basically a small flat spade on the end of the shaft which fits into the tps.  It does operate the switch...... but should the be an adaptor on the end of the shaft that fully  fills the 'hole' in the tps... And if so where could it get one...? 

 

Many thanks 

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

No - that sounds correct.

post up a picture. Are you sure the TPS you have is correct ? And are the butterflies closed?

What voltage are you getting?


Only here once

Share this post


Link to post
Share on other sites

Barry,

 

Thanks for the reply.  I can only get a voltage if I rotate the tps clockwise about 30 degrees, to give the required 0.5-0.7 volts.  I have to clamp in this position as the holes are way out of line.  The throttles are closed and it will start and run (unevenly) in this position. I think the previous owner had dismantled the bodies for powder coating, but i can't see how you could reassemble the butterflies the wrong way round anyway....very puzzling.

I got a new tps from SJ and it's just the same as the one the car came with.

i will get some photos tomorrow

 

Alan

Share this post


Link to post
Share on other sites

The TPS fits on the end of the rod which the butterflies are attached to.

it should be as simple as locate the TPS onto this and bolt on. Then fine adjust for 0.51v or thereabouts. The slot in the TPS is like a bow tie shape so there’s a whole lot of movement in that.

pics might help - it’s sounding to me like the TPS might be wrong 


Only here once

Share this post


Link to post
Share on other sites
15 hours ago, alzmoore said:

Hello,  I've finally managed  to get back to my 1989 SE project..  I can't get the tps to align properly with the screw holes on the end of the throttle bodies and get the right voltage and my mate is convinced that there is an adaptor missing from the end of the throttle spindle.  The shaft end is basically a small flat spade on the end of the shaft which fits into the tps.  It does operate the switch...... but should the be an adaptor on the end of the shaft that fully  fills the 'hole' in the tps... And if so where could it get one...? 

 

Many thanks 

Just seen this thread , sorry for slow reply... The answer to your question is. YES see pic ...

The little Item just left of the std TPS  at the top of pic is what you need... It slots over the Throttle spindle bayonet end and adapts to the TPS insert......    hope that helps answer your question and solves your problem

1873504573_TPS006.thumb.JPG.a2d4769d671bcf40a44d8d57cf1eff33.JPG

  • Thanks 1

Share this post


Link to post
Share on other sites

I don’t recall ever seeing that on any of mine and it’s not on the parts book piccys either @CHANGES - I’m puzzled a bit.

id go and take one off - but the laptops knackered and I won’t be able to set the voltage - so I probably just never looked properly 


Only here once

Share this post


Link to post
Share on other sites

Job for a 3D printer 👍


Only here once

Share this post


Link to post
Share on other sites

Bob, It looks like you are right. Sj can't source it... So scratching my head now for a solution... I'll try the other spares outfits and scrappers, but if anyone has any ideas please let me know. 

 

Thanks 

Share this post


Link to post
Share on other sites

Vauxhall nova and corsa


Only here once

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...