free hit
counters
Engine shut off in traffic - Engine & Ancilliaries/Gearbox - The Lotus Forums Jump to content
Sign in to follow this  
Relic222

Engine shut off in traffic

Recommended Posts

Morning all, I had a bit of a worrying moment this morning when driving to work. It was an fairly busy day on the roads and I was stuck in traffic for much of the journey, then when crawling in first gear through Beaconsfield I heard a small squeak behind me and the engine shut off - electrics were still on and I had the engine, battery and oil lights on the dash (as if you'd turned the key to the first position). I tried to turn it back on while still rolling, but it wouldn't start. Fortunately I managed to roll into a driveway so I was off the road and tried a couple more times, on the second time it started but then shut off again after a few seconds. After waiting for a minute or two I tried again and this time it started okay, I managed to nurse it to the office (just the other side of Beaconsfield) but could hear some belt squeaking noise from the engine. 

Could it have been the engine overheated? Unfortunately the right hand screen on my dash doesn't work so I can't see the engine temp, but I'm aware it gets hot in traffic (can see the heat coming off the bonnet etc). There weren't any lights on the dashboard (no engine warning light etc) when I managed to get it started again. I will go the long way home which has less traffic so I can keep it moving, but I'm obviously a bit concerned.

Share this post


Link to post
Share on other sites

Upgrade today to remove Google ads and support TLF.

Have you got a code reader?

Share this post


Link to post
Share on other sites

From your description of belt squealing it sounds as though something is possibly jamming and the belt then slips and squeaks. Until you find out what is stopping and causing the belt to slip I wouldn't attempt to start and drive it. Hoffmans at Henley isn't too far from Beaconsfield. I'd ask them to take a look.

 

 

Share this post


Link to post
Share on other sites

Update, just tried to start the car at lunch and it only stays on for a few seconds. Will need to get it picked up. 

Share this post


Link to post
Share on other sites
7 hours ago, Relic222 said:

Update, just tried to start the car at lunch and it only stays on for a few seconds. Will need to get it picked up. 

Sorry to hear that, hope it's easily sorted. 

Share this post


Link to post
Share on other sites

So the AC compressor seized apparently, so it'll need a new compressor clutch and belt. Been quoted £1700 from Hofmann's, using the Toyota compressor. Ouch... 

Share this post


Link to post
Share on other sites

Have just called a local Lotus specialist to get a quote too. Fingers crossed it's cheaper! Sounds like if the AC clutch is okay the car should still drive with the AC turned off. 

Share this post


Link to post
Share on other sites

If you take a look at this thread, you might be able to save some cash....

 

Share this post


Link to post
Share on other sites

Thanks, useful to see prices people have found. Hofmann's did quote 3 hours labour, which is what others are saying, and I think he said the compressor was £570, so I'm not entirely sure where the £1200 jump was. Will see what the other garage quotes. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  


×